Jun 21, 2012, by admin
UNetbootin for Mac OS X can be used to computerize the process of extracting the Ubuntu ISO file to USB, and making the USB drive bootable. The resulting USB drive, however, can be booted on PCs only. If attempting to make a USB drive that can be booted from a Mac, follow the instructions below.
We would encourage Mac users to download Ubuntu Desktop Edition by burning a CD for the time being. But if you would prefer to use a USB, please follow the instructions below.
Note: this procedure requires an .img file that you will be needed to create from the .iso file you download.
TIP: Drag and Drop a file from Finder to Terminal to ‘paste’ the full path without typing and risking type errors.
hdiutil convert -format UDRW -o ~/path/to/target.img ~/path/to/ubuntu.iso
)
4.Note: OS X tends to put the .dmg ending on the output file automatically.
5.Run
diskutil list
to get the current list of devices
6.Insert your flash media
7.Run
diskutil list
again and determine the device node assigned to your flash media (e.g. /dev/disk2)
8.Run
diskutil unmountDisk /dev/diskN
(replace N with the disk number from the last command; in the previous example, N would be 2)
9.Execute
sudo dd if=/path/to/downloaded.img of=/dev/diskN bs=1m
(replace /path/to/downloaded.img with the path where the image file is located; for example, ./ubuntu.img or ./ubuntu.dmg).
10.Using /dev/rdisk instead of /dev/disk may be faster.
11.Run
diskutil eject /dev/diskN
and remove your flash media when the command completes
12. Restart your Mac and press alt while the Mac is restarting to choose the USB-Stick
Please notice: While all of the info and above commands are executed properly on a MacBook Air 3,2 (that is the 2010 version 13″ version of the Air) the end result will not create a bootable USB device, at least not with the image for Ubuntu 10.10 64-bit. When booting of the USB device the following message or something similar will appear: “Missing operating system” and the process is auto-matically halted.
To get the USB device (e.g. a USB stick) to show up at all in the boot menu you also may have to reboot/turn on/off the computer a couple of times and also re sync the partition tables using rEFIt. After doing this the USB should then appear as a bootable device while holding in the alt or c key when you are rebooting the computer. Notice that both the computers built in boot loader and rEFIt will identify the USB device as a Windows device, but that’s not a problem and expected.
A work around to the-usb-device-is-not-booting-problem is to:
Alternatively, burning a CD and installing via an external CD-drive will work fine on the Macbook Air 3,2.